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Foreword 
Copyright 
Copyright ©2020  
Decowell has the property of the copyright and reserves all rights. Any organizations and 
individuals shall not copy or reproduce part or all of the Manual without the prior written consent 
of the Company. Content of the Manual shall not be spread in any way. 

 and are trademarks of the Company. 
Other trademarks appearing in the Manual, if any, are owned by respective owner. 
The Manual will be updated from time to time due to upgrading of the product version or any other 
reason. Unless otherwise agreed, the Manual is only for the purpose of reference. Any 
representations, information and suggestions in the Manual shall constitute any explicit or implicit 
guarantee under no circumstance. 
 
Scope of Application 
The Manual is applicable for FS Series Remote IO System. 
Brief Introductions 
The Manual mainly describes the technical specifications, installation and commissioning of FS 
Series Remote IO Module, including: 
 System Overview: It mainly describes product order information and production 

composition, system structure, product transportation and storage environment of FS Series 
Remote IO Module; 

 Production Introduction: It provides the technical parameters of FS Series Remote IO Module; 
 Guidance for Installation and Removal: It describes how to install and remove the FS Series 

Remote IO Module; 
 M&E Drawing: Dimensional Drawing and Electrical Wiring Diagram of the FS Remote 

Module 
 User Guide: Describe the connection and communication between the FS Series Remote IO 

Module and each main PLC through examples. 

Precautions 
The Manual describes the usage of the FS Series Remote IO Module under WELL-LINK in details. 
Reader of this Manual is expected to be the personnel having engineering experience. Decowell is 
not responsible for any consequent caused by or relating to the usage of the Manual.  
Please carefully read the precautions relating to the device before any trial use of the device. The 
user is expected to follow the safety preventive measures and operation procedures on and in respect 
of installation and commissioning of the device. Refer to the following symbols and notes for 
information about any potential danger and damage caused by the erroneous operation of the device. 

Warning
The symbol indicates that

“Personal death or injuries may occur due to the danger caused by the noncompliance with requirement.”
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Applicable Object 
With provision of information on and in respect of installation and commissioning of the FS Series 
Remote IO Module, this Manual is compiled for the engineers, installation staff, maintenance staff 
and electricians having the general knowledge of automation. 

Recycling and Disposal 
Please contact the certified service station which is qualified for disposal of the electronic wastes so 
as to assure that the recycling and disposal of the old device are consistent with the requirement for 
environment protection. 

Online Support 
Except for the Manual, more product information is available from the official website. 
http://www.welllinkio.com 
  

Note
The symbol indicates that
“Minor or medium injury may be caused to human and/or device damage may occur due to the danger caused by the noncompliance with 

requirement.”

Prompt
The symbol indicates

“any necessary supplement or explanation for description of operation.”

http://www.welllinkio.com/
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1 Overview of FS Series Remote IO System 

1.1 Definition of Remote IO 
Remote IO is also called the distributive IO. It is the electronic device that frequently uses the 
transmission technology (e.g. industrial Canbus) to send to and receive from the main electronic 
device (e.g. DCS, PLC and PC) the input/output signal in the process or in the factory automation.  
1.2 Composition of FS Series Remote IO Module 
The FS Series Remote IO Module mainly consists of the module system indicator, system power 
source, output/input channel, communication interface, IO channel indicator, etc. See Fig.1-2 for 
details. 

 
Fig. 1-2 Composition of FS Series Remote IO Module 

1.3 Characteristics of FS Series Remote IO Module 
The FS Remote IO adopts the one-piece structural design which indicates the communication 
interface, input/output IO interface, system and IO indicators, etc. Its advantages include high 
degree of integration, various communication protocols, compact size and easy operation. 
1.4 Application Field of FS Series Remote IO Module 
The FS Series Remote IO Module is widely used in various fields, e.g. new energy, lithium, non-
standard automation, robot, numerical control machine, intelligent garage, logistics sorting, 
education device, environment protection, heating system, etc.  

Module System Indicator

Input Channel

Input IO Power Source

Communication Interface

System Power Source

IO Channel Indicator

Output Channel

Input IP Power Source
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2 Parameters of FS Series Remote IO Module 

2.1 Naming Rules for FS Series Remote IO Module 

 

2.2 Parameters of Module Communication Protocol Interface 
It mainly provides parameters of the module including the bus protocol, interface type, interface 
mode and baud rate.  
2.2.1 PROFINET Protocol 

Parameters of PROFINET Module Communication 
Protocol Interface 

Bus Protocol PROFINET 

Interface Type Industry EtherNET 

Interface Mode 2×RJ45 

baud rate 100Mbps 
Communication 

Distance 
100m (Interstation Distance) 

Electrical Isolation Provided 
Descriptions of PN Module System Indicators 

No. Indicator Name Color Status Definition 
ON Power supply is normal. 

1 POWER Power Indicator Green 
OFF Disconnected or Erroneous 

ON 
device is running and communication 

is normal. 2 RUN Operation Indicator Green 
OFF The system is power off or abnormal. 

3 SF --- --- --- --- 
ON Communication is abnormal. 

4 BF 
System Fault 

Indicator 
Red 

OFF device is running and communication 

EC: EtherCAT Bus
PN: PROFINET Bus
DN: DeviceNet Bus
CL: CC-Link Bus

Digital Quantities Input Point
8: 8-loop Digital Quantities Input
H: 16-loop Digital Quantities Input
S: 32-loop Digital Quantities Input
Digital Quantities Output Point:
8: 8-loop Digital Quantities Output
H: 16-loop Digital Quantities Output
S: 32-loop Digital Quantities Output

Analog Quantities 
Input Point
Analog Quantities 
Output Point

Types of Analog Quantities Input:
0: Input of Voltage Signal
1: Input of Current Signal
2: Input of Thermal Resistance Signal
3: Thermal Couple Signal
C: Compatible Voltage and Current Signal
Types of Analog Quantities Input:
0: Input of Voltage Signal
1: Input of Current Signal
C: Compatible Voltage and Current Signal

Types of Digital Quantities Input:
0: Effective Low Electrical Level (NPN)
1: Effective High Electrical Level (PNP)
C: Compatible (NPN & PNP)
Types of Digital Quantities Output:
0: Effective Low Electrical Level (NPN)
1: Effective High Electrical Level (PNP)
2: Relay
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is normal. 
 
Descriptions of PN2 Module System Indicators 

No
. 

Indicat
or 

Name Color Status Definition 

ON Power supply is normal. 
1 

POWE
R 

Power Indicator Green 
OFF Disconnected or Erroneous 

ON 
device is running and communication 

is normal. 2 RUN Operation Indicator Green 
OFF The system is power off or abnormal. 

3 SF --- --- --- --- 
ON Communication is abnormal. 

4 BF 
System Fault 

Indicator 
Red 

OFF 
device is running and communication 

is normal. 

Flashing 5HZ 
The indicator is flashing during 

upgrading or transmission. 

Flashing 1HZ 
The indicator is flashing when pressing 

down the Reset button. 
ON Resetting is completed. 

5 MT 
Maintenance 

Indicator 
Green 

OFF 
The device is not in the maintenance 
status. 

 
2.2.2 EtherCAT Protocol 

Parameters of EtherCAT Module Communication Protocol 
Interface 

Bus Protocol EtherCAT 

Interface Type Industry EtherNET 

Interface Mode 2×RJ45 

baud rate 100Mbps 
Communication 

Distance 
100m (Interstation Distance) 

Electrical Isolation Provided 
Descriptions of EtherCAT Module System Indicator 

No. Indicator Name Color Status Definition 
ON The power supply is normal. 

1 POWER Power Indicator Green 
OFF Disconnected or Erroneous 

ON 
The device is in OP status and the running 

is normal. 

OFF 
The device is in INIT status or the initial 
status. 

Flashing 
The device is in PRE-OP status and the 
communication initialization is completed. 

2 RUN 
Operation 
Indicator 

Green 

Flashing Once The device is in SAFE-OP status. SDO and 
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PDO are disabled. 
ON The application controller is faulty. 
OFF No Error 

Flashing 
Twice 

Process Data Watchdog Timeout/EtherCAT 
Watchdog Timeout 

Flashing Once Local Error 

3 ERR 
System Fault 

Indicator 
Red 

Flashing Configuration Error 
 
2.2.3 CC-Link Protocol 
 Parameters of CC-link Module Communication Protocol Interface 

Parameters of CC-Link Module Communication Protocol 
Interface 

Bus Protocol CC-Link 

Working Mode CC-Link Remote IO Station 

Link Mode Shielded Twisted Pair 

Baud Rate 156kbps～10Mbps 
Address 

Configuration 
1～64 

Electrical 
Isolation 

Provided 

 CC-Link Remote IO Module Dial Setting 

 

CC-Link Baud Rate Setting 
Dial 

Position 
No. 

Baud Rate 
Transmission 

Distance 

0 156kbps 1200m 
1 625kbps 600m 
2 2.5Mbps 200m 
3 5Mbps 150m 
4 10Mbps 100m 

Descriptions of CC-Link Module System Indicators 

No. Indicator Name Color Status Definition 
ON The power Supply is normal. 

1 POWER 
Power 

Indicator 
Green 

OFF 
The device is disconnected from power or 

faulty. 

ON 
The device is running and the communication 

is normal. 2 RUN 
Operation 
Indicator 

Green 
OFF Link is not established. 
ON Module communication is abnormal. 

3 ERR 
System Fault 

Indicator 
Red 

OFF Module communication is Normal. 
 
2.2.4 DeviceNet Protocol 
 Parameters of DeviceNet Module Communication Protocol Interface 

Baud Rate 
Setting

Station 
No. x 10

Station 
No. x 1
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Parameters of DeviceNet Module Communication Protocol 
Interface 

Bus Protocol DeviceNet 

Link Mode Shielded Twisted Pair 

Baud Rate 125kbps/250kbps/500kbps 
Address 

Configuration 
0～63 

Electrical 
Isolation 

Provided 

 Definition of DeviceNet Remote IO Module Communication Interface 

 
 DeviceNet Remote IO Module Dial Setting 

 

DeviceNet Baud Rate Setting 
0 125kbps 
1 250kbps 
2 500kbps 

 
Definition of DeviceNet Module System Indicator 

No. Indicator Name Color Status Definition 
ON The power supply is normal. 

1 POWER Power Indicator Green 
OFF 

The device is disconnected from power or 
faulty. 

ON 
The device is running and the 

communication is normal. 2 RUN 
Operation 
Indicator 

Green 
OFF Link is not established. 
ON Module communication is abnormal. 

3 ERR 
System Fault 

Indicator 
Red 

OFF Module communication is Normal. 

DeviceNet Communication Interface 
Position 

No. 
Signal Definition 

1 V+ Positive Electrode 

2 CH Positive Data Signal 

3 SLD Shielded Wire 

4 CL Negative Data Signal 

 

5 V- Negative Electrode 

Baud Rate 
Setting

Station 
No. x 10

Station 
No. x 1
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2.2.5 CC-Link IE Field Basic Protocol 

Parameters of CC-Link IE Field Basic Module 
Communication Protocol Interface 

Bus Protocol CC-Link IE Field Basic 

Interface Type Industry EtherNET 

Interface Mode 2×RJ45 

Baud Rate 100Mbps 
Communication 

Distance 
100m (Interstation Distance) 

Electrical Isolation Provided 
Definition of CC-Link IE Field Basic Module System Indicators 
No. Indicator Name Color Status Definition 

ON The power supply is normal. 
1 POWER Power Indicator Green OFF The device is disconnected from power or 

faulty. 

ON The device is running and the 
communication is normal. 

OFF Link is not established. 2 RUN Operation 
Indicator Green 

Flashing Detect the signal about restoring the factory 
setting. 

ON Module communication is abnormal. 3 ERR System Fault 
Indicator Red OFF Module communication is normal. 

2.2.6 CANopen Protocol 
 Parameters of CANopen Module Communication Protocol Interface 

Parameters of CANopen Module Communication Protocol Interface 

Bus Protocol CANopen 

Link Mode Shielded Twisted Pair 

Baud Rate 10kbps～1Mbps 

Address Setting Dial Switch Setting 
Communication 

Distance 
The max. Communication distance relies on the 

baud rate. 
Electrical 
Isolation 

Provided 

 Definition of CANopen Remote IO Module Communication Interface 

 
 CACANopen Remote IO Module Dial Setting 

CANopen Communication Interface 
Position 

No. 
Signal Signal Definition 

1 +V Positive Electrode 

2 CH Positive Data Signal 

3 SLD Shielded Wire 

4 CL Negative Data Signal 
 5 -V Negative Electrode 
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CANopen Baud Rate Setting 
0 10kbps 
1 20kbps 
2 50kbps 
3 100kbps 
4 125kbps 
5 250kbps 
6 500kbps 
7 1000kbps 

 
Definition of CC-Link IE Field Basic Module System Indicators 
No. Indicator Name Color Status Definition 

ON The power supply is normal. 
1 POWER 

Power 
Indicator 

Green 
OFF 

The device is disconnected from 
power or faulty. 

ON 
The module is in the operation status 

and the communication is normal. 

OFF 
The module is in the initialization 

status. 
1 Long Flash and 

OFF 
The module is disabled. 

2 RUN 
Operation 
Indicator 

Green 

5HZ Quick Flash 
The module is in the pre-operation 

status. 
ON The module is faulty. 

3 ERR 
System Fault 

Indicator 
Red 

OFF The module is in the operation status. 
2.2.7 EtherNet/IP Protocol 
 

Parameters of EtherNet/IP Module Communication 
Protocol Interface 

Bus Protocol EtherNet/IP 

Interface Type Industry EtherNET 

Interface Mode 2×RJ45 

Baud Rate 100Mbps 
Communication 

Distance 
100m (Interstation Distance) 

Electrical Isolation Provided 
Definition of EtherNet/IP Module System Indicators 
No. Indicator Name Color Status Definition 

ON The power supply is normal. 
1 POWER Power Indicator Green OFF The device is disconnected from power 

source or faulty. 
ON The device operation is normal. 

2 MS Module Status 
Indicator Green 1HZ 

Flashing 
The device is in the standby status and not 

configured. 

Baud Rate 
Setting

Station 
No. x 10

Station 
No. x 1
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1HZ 
Flashing 

Self-inspection: The device is being tested 
for energization. Red and 

Green OFF The device is not provided with power 
source. 

ON 
Main Fault: The device has significant fault 
leading to non-recoverable result as found in 
the test. Red 

1HZ 
Flashing 

No Power Source: The device is not 
provided with power source. 

ON Linked: The device has at least 1 
established link. Green 1HZ 

Flashing 
No Link: The device has not established 

link. 
1HZ 

Flashing 
Self-inspection: The device is being tested 

for energization. Red and 
Green OFF The device is disconnected from power 

source or has no IP address. 
ON Repeated IP Address 

3 NS Network Status 
Indicator 

Red 1HZ 
Flashing 

Link Timeout: 1 or more link timeout 
targeting the device 

Flashing 
5HZ 

The indicator is flashing in the process of 
upgrading. 

Flashing 
1HZ 

The indicator is flashing when pressing 
down the Reset Button. 

ON Resetting is completed. 

4 MT Maintenance Status 
Indicator Green 

OFF The device is not in the maintenance status. 
2.3 Technical Parameters of Module Input/Output Channel 
2.3.1 XX-8800-C0NN 
Note: XX means that the Bus Protocol can be selected (e.g. PN, EC, CL, CI, CA, etc.). 
Input/output parameters and external dimensions in the module shall be consistent. 
 XX-8800-C0NN One-piece Module Model 

Model Descriptions 
XX-8800-

C0NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (NPN) 
XX-8800-

C1NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (PNP) 
XX-8800-

C2NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (Relay) 
XX-HH00-

C0NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (NPN) 
XX-HH00-

C1NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (PNP) 
XX-S000-

CNNN 
32-channel digital quantities input (NPN&PNP) 

XX-0S00-
N0NN 

32-channel digital quantities output  (NPN) 

XX-0S00-
N1NN 

32-channel digital quantities output (PNP) 

 Module Parameters 
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2.3.2 XX-8800-C1NN 
Note: XX means that the Bus Protocol can be selected (e.g. PN, EC, CL, CI, CA, etc.). 
Input/output parameters and external dimensions in the module shall be consistent. 
 XX-8800-C1NN One-piece Module Model 

Model Descriptions 

XX-8800-C0NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (NPN) 

XX-8800-C1NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (PNP) 

Technical Parameters 

Model XX-8800-C0NN 

Product Name 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (NPN) 

Bus Protocol 
PROFINET, EtherCAT, CC-Link, DeviceNet 

CC-Link IE Field Basic, CANopen 
Rated Input Voltage 24V (18～36V) 

Current Consumption 38mA 

Input Channel Parameters 

Number of Input Channel 8 

Input Signal Type NPN&PNP Compatible (Transistor) 

NPN Signal Electrical Level 0～5V 

PNPSignal Electrical Level 15～30V 
Single-channel Current 

Consumption 
5mA 

Port Protection Over-voltage Shock Protection 

Electrical Isolation AC500V 

Output Channel Parameters 

Number of Output Channel 8 

Input Signal Type NPN (Transistor) 

Rated Electrical Level 0V(Max: 1.5V) 

Single-channel Rated Current 
Max：0.5A (Total Output Current of 8 Channels at the same time: 

2A) 
Port Protection Over-voltage and Over-current Protection 

Electrical Isolation AC500V 

Physical Parameters 

Dimensions 90mm×100mm×45.4mm 

Working Temperature -10～55℃ 

Storing Temperature -25～85℃ 

Relative Humidity 95% No Condensation 

Protection Grade IP20 
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XX-8800-C2NN 
8-channel digital quantities input(NPN&PNP)8-channel digital 

quantities output (Relay) 

XX-HH00-C0NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (NPN) 

XX-HH00-C1NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (PNP) 
XX-S000-CNNN 32-channel digital quantities input (NPN&PNP) 

XX-0S00-N0NN 32-channel digital quantities output (NPN) 

XX-0S00-N1NN 32-channel digital quantities output (PNP) 
 Module Parameters 

Technical Parameters 

Model XX-8800-C1NN 

Product Name 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (PNP) 

Bus Protocol 
PROFINET, EtherCAT, CC-Link, DeviceNet 

CC-Link IE Field Basic, CANopen 
Rated Input 

Voltage 
24V (18～36V) 

Current 
Consumption 

38mA 

Input Channel Parameters 
Number of Input 

Channel 
8 

Input Signal Type NPN&PNP Compatible (Transistor) 
NPN Signal 

Electrical Level 
0～5V 

PNP Signal 
Electrical Level 

15～30V 

Single-channel 
Current 

Consumption 
5mA 

Port Protection Over-voltage Shock Protection 

Electrical Isolation AC500V 

Output Channel Parameters 
Number of Output 

Channel 
8 

Input Signal Type PNP (Transistor) 
Rated Electrical 

Level 
24V(18～36V) 

Single-channel 
Rated Current 

Max：0.5A (Total Output Current of 8 Channels at the same time: 
2A) 

Port Protection Over-voltage and Over-current Protection 
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2.3.3 XX-8800-C2NN 
Note: XX means that the Bus Protocol can be selected (e.g. PN, EC, CL, CI, CA, etc.). 
Input/output parameters and external dimensions in the module shall be consistent. 
 XX-8800-C2NN One-piece Module Model 

Model Descriptions 

XX-8800-C0NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (NPN) 

XX-8800-C1NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (PNP) 

XX-8800-C2NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (Relay) 

XX-HH00-C0NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (NPN) 

XX-HH00-C1NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (PNP) 
XX-S000-CNNN 32-channel digital quantities input (NPN&PNP) 

XX-0S00-N0NN 32-channel digital quantities output (NPN) 

XX-0S00-N1NN 32-channel digital quantities output (PNP) 
 Module Parameters 

Electrical Isolation AC500V 

Physical Parameters 

Dimensions 90mm×100mm×45.4mm 
Working 

Temperature 
-10～55℃ 

Storing 
Temperature 

-25～85℃ 

Relative Humidity 95% No Condensation 

Protection Grade IP20 

Technical Parameters 

Model XX-8800-C2NN 

Product Name 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (Relay) 

Bus Protocol 
PROFINET, EtherCAT, CC-Link, DeviceNet 

CC-Link IE Field Basic, CANopen 
Rated Input 

Voltage 
24V (18～36V) 

Current 
Consumption 

38mA 

Input Channel Parameters 
Number of Input 

Channel 
8 

Input Signal Type NPN&PNP Compatible (Transistor) 
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2.3.4 XX-HH00-C0NN 
Note: XX means that the Bus Protocol can be selected (e.g. PN, EC, CL, CI, CA, etc.). 
Input/output parameters and external dimensions in the module shall be consistent. 
 XX-HH00-C0NN One-piece Module Model 

Model Descriptions 

XX-8800-C0NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (NPN) 

XX-8800-C1NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (PNP) 

XX-8800-C2NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (Relay) 

XX-HH00-C0NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (NPN) 

XX-HH00-C1NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (PNP) 

NPN Signal 
Electrical Level 

0～5V 

PNP Signal 
Electrical Level 

15～30V 

Single-channel 
Current 

Consumption 
5mA 

Port Protection Over-voltage Shock Protection 

Electrical Isolation AC500V 

输出通道参数 
Number of Output 

Channel 
8 

Input Signal Type Relay (Remain ON) 
Rated Electrical 

Level 
240VAC/30VDC 

Single-channel 
Rated Current 

5A 

Port Protection Over-voltage and Over-current Protection 

Electrical Isolation AC500V 

Physical Parameters 

Dimensions 90mm×100mm×45.4mm 
Working 

Temperature 
-10～55℃ 

Storing 
Temperature 

-25～85℃ 

Relative Humidity 95% No Condensation 

Protection Grade IP20 
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XX-S000-CNNN 32-channel digital quantities input (NPN&PNP) 

XX-0S00-N0NN 32-channel digital quantities output (NPN) 

XX-0S00-N1NN 32-channel digital quantities output (PNP) 
 Model Parameters 

Technical Parameters 

Model XX-HH00-C0NN 

Product Name 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (NPN) 

Bus Protocol 
PROFINET, EtherCAT, CC-Link, DeviceNet 

CC-Link IE Field Basic, CANopen 
Rated Input 

Voltage 
24V (18～36V) 

Current 
Consumption 

40mA 

Input Channel Parameters 
Number of Input 

Channel 
16 

Input Signal Type NPN&PNP Compatible (Transistor) 
NPN Signal 

Electrical Level 
0～5V 

PNP Signal 
Electrical Level 

15～30V 

Single-channel 
Current 

Consumption 
5mA 

Port Protection Over-voltage Shock Protection 

Electrical Isolation AC500V 

Output Channel Parameters 
Number of Output 

Channel 
16 

Input Signal Type NPN (Transistor) 
Rated Electrical 

Level 
0V (Max: 1.5V) 

Single-channel 
Rated Current 

Max：0.5A (Total Output Current of 8 Channels at the same time: 
2A) 

Port Protection Over-voltage and Over-current Protection 

Electrical Isolation AC500V 

Physical Parameters 

Dimensions 90mm×100mm×45.4mm 
Working 

Temperature 
-10～55℃ 
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2.3.5 XX-HH00-C1NN 
Note: XX means that the Bus Protocol can be selected (e.g. PN, EC, CL, CI, CA, etc.). 
Input/output parameters and external dimensions in the module shall be consistent. 
 XX-HH00-C1NN One-piece Module Model 

Model Descriptions 

XX-8800-C0NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (NPN) 

XX-8800-C1NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (PNP) 

XX-8800-C2NN 
8-channel digital quantities input(NPN&PNP)8-channel digital 

quantities output (Relay) 

XX-HH00-C0NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (NPN) 

XX-HH00-C1NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (PNP) 
XX-S000-CNNN 32-channel digital quantities input (NPN&PNP) 

XX-0S00-N0NN 32-channel digital quantities output (NPN) 

XX-0S00-N1NN 32-channel digital quantities output (PNP) 
 Module Parameters 

Storing 
Temperature 

-25～85℃ 

Relative Humidity 95% No Condensation 

Protection Grade IP20 

Technical Parameters 

Model XX-HH00-C1NN 

Product Name 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (PNP) 

Bus Protocol 
PROFINET, EtherCAT, CC-Link, DeviceNet 

CC-Link IE Field Basic, CANopen 
Rated Input 

Voltage 
24V (18～36V) 

Current 
Consumption 

40mA 

Input Channel Parameters 
Number of Input 

Channel 
16 

Input Signal Type NPN&PNP Compatible (Transistor) 
NPN Signal 

Electrical Level 
0～5V 

PNP Signal 
Electrical Level 

15～30V 

Single-channel 5mA 
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2.3.6 XX-S000-CNNN 
Note: XX means that the Bus Protocol can be selected (e.g. PN, EC, CL, CI, CA, etc.). 
Input/output parameters and external dimensions in the module shall be consistent. 
 XX-S000-CNNN One-piece Module Model 

Model Descriptions 

XX-8800-C0NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (NPN) 

XX-8800-C1NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (PNP) 

XX-8800-C2NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (Relay) 

XX-HH00-C0NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (NPN) 

XX-HH00-C1NN 
16-channel digital quantities input (NPN&PNP) 16-channel digital 

quantities output (PNP) 
XX-S000-CNNN 32-channel digital quantities input (NPN&PNP) 

XX-0S00-N0NN 32-channel digital quantities output (NPN) 

XX-0S00-N1NN 32-channel digital quantities output (PNP) 
 Module Parameters 

Current 
Consumption 

Port Protection Over-voltage Shock Protection 

Electrical Isolation AC500V 

Output Channel Parameters 
Number of Output 

Channel 
16 

Input Signal Type PNP (Transistor) 
Rated Electrical 

Level 
24V (18～36V) 

Single-channel 
Rated Current 

Max: 0.5A (Total Output Current of 8 Channels at the same time: 
2A) 

Port Protection Over-voltage and Over-current Protection 

Electrical Isolation AC500V 

Physical Parameters 

Dimensions 90mm×100mm×45.4mm 
Working 

Temperature 
-10～55℃ 

Storing 
Temperature 

-25～85℃ 

Relative Humidity 95% No Condensation 

Protection Grade IP20 
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2.3.7 XX-0S00-N0NN 
Note: XX means that the Bus Protocol can be selected (e.g. PN, EC, CL, CI, CA, etc.). 
Input/output parameters and external dimensions in the module shall be consistent. 
 XX-0S00-N0NN One-piece Module Model 

Model Descriptions 

XX-8800-C0NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (NPN) 

XX-8800-C1NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (PNP) 

XX-8800-C2NN 
8-channel digital quantities input (NPN&PNP) 8-channel digital 

quantities output (Relay) 
XX-HH00-C0NN 16-channel digital quantities input (NPN&PNP) 16-channel digital 

Technical Parameters 

Model XX-HH00-C0NN 

Product Name 32-channel digital quantities input (NPN&PNP) 

Bus Protocol 
PROFINET, EtherCAT, CC-Link, DeviceNet 

CC-Link IE Field Basic, CANopen 
Rated Input 

Voltage 
24V (18～36V) 

Current 
Consumption 

40mA 

Input Channel Parameters 
Number of Input 

Channel 
32 

Input Signal Type NPN&PNP Compatible (Transistor) 
NPN Signal 

Electrical Level 
0～5V 

PNP Signal 
Electrical Level 

15～30V 

Single-channel 
Current 

Consumption 
5mA 

Port Protection Over-voltage Shock Protection 

Electrical Isolation AC500V 

Physical Parameters 

Dimensions 90mm×100mm×45.4mm 
Working 

Temperature 
-10～55℃ 

Storing 
Temperature 

-25～85℃ 

Relative Humidity 95% No Condensation 

Protection Grade IP20 



FS System Remote IO-User Manual                               

 

23

quantities output (NPN) 

XX-HH00-C1NN 
16-channel digital quantities input (NPN&PNP)16-channel digital 

quantities output (PNP) 
XX-S000-CNNN 32-channel digital quantities input (NPN&PNP) 

XX-0S00-N0NN 32-channel digital quantities output (NPN) 

XX-0S00-N1NN 32-channel digital quantities output (PNP) 
 Module Parameters 

2.3.8 XX-0S00-N1NN 
Note: XX means that the Bus Protocol can be selected (e.g. PN, EC, CL, CI, CA, etc.). 
Input/output parameters and external dimensions in the module shall be consistent. 
 XX-HH00-C1NN One-piece Module Model 

Model Descriptions 

XX-8800-C0NN 
8-channel digital quantities input(NPN&PNP)8-channel digital 

quantities output(NPN) 

Technical Parameters 

Model XX-0S00-N0NN 

Product Name 32-channel digital quantities output (NPN) 

Bus Protocol 
PROFINET, EtherCAT, CC-Link, DeviceNet 

CC-Link IE Field Basic, CANopen 
Rated Input 

Voltage 
24V (18～36V) 

Current 
Consumption 

40mA 

Output Channel Parameters 
Number of Output 

Channel 
32 

Input Signal Type NPN (Transistor) 
Rated Electrical 

Level 
0V (Max: 1.5V) 

Single-channel 
Rated Current 

Max: 0.5A (Total Output Current of 8 Channels at the same time: 
2A) 

Port Protection Over-voltage and Over-current Protection 

Electrical Isolation AC500V 

Physical Parameters 

Dimensions 90mm×100mm×45.4mm 
Working 

Temperature 
-10～55℃ 

Storing 
Temperature 

-25～85℃ 

Relative Humidity 95% No Condensation 

Protection Grade IP20 
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XX-8800-C1NN 
8-channel digital quantities input(NPN&PNP)8-channel digital 

quantities output(PNP) 

XX-8800-C2NN 
8-channel digital quantities input(NPN&PNP)8-channel digital 

quantities output(继电器) 

XX-HH00-C0NN 
16-channel digital quantities input(NPN&PNP)16-channel digital 

quantities output(NPN) 

XX-HH00-C1NN 
16-channel digital quantities input(NPN&PNP)16-channel digital 

quantities output(PNP) 
XX-S000-CNNN 32-channel digital quantities input (NPN&PNP) 

XX-0S00-N0NN 32-channel digital quantities output (NPN) 

XX-0S00-N1NN 32-channel digital quantities output (PNP) 
 Module Parameters 

Technical Parameters 

Model XX-0S00-N1NN 

Product Name 32-channel digital quantities output (PNP) 

Bus Protocol 
PROFINET, EtherCAT, CC-Link, DeviceNet 

CC-Link IE Field Basic, CANopen 
Rated Input 

Voltage 
24V (18～36V) 

Current 
Consumption 

40mA 

Output Channel Parameters 
Number of Output 

Channel 
32 

Input Signal Type PNP (Transistor) 
Rated Electrical 

Level 
24V (18～36V) 

Single-channel 
Rated Current 

Max: 0.5A (Total Output Current of 8 Channels at the same time: 
2A) 

Port Protection Over-voltage and Over-current Protection 

Electrical Isolation AC500V 

Physical Parameters 

Dimensions 90mm×100mm×45.4mm 
Working 

Temperature 
-10～55℃ 

Storing 
Temperature 

-25～85℃ 

Relative Humidity 95% No Condensation 

Protection Grade IP20 
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3 Module Installation 

3.1 Basic Knowledge 
The Protection grade applicable to FS Series Module is IP20, indicating that FS Series Module can 
only be installed for the guide rail, control cabinet, electrical operation room and any other dry 
environment (Protection Grade: IP20). The machine cabinet, control cabinet or control room shall 
be provided with the safety measures so as to prevent electric shock and fire spread. 
FS Series Module can be installed onto the guide rail that complies with EN 60715 (35×7.5 mm or 
35×15 mm). The guide rail shall be separately grounded in the control cabinet except that the guide 
rail is installed on the grounded galvanized installation plate. In this circumstance, the guide rail 
will be waived from the separate grounding. 
3.2 Installation Clearance 
The minimum clearance must be maintained upon installation and removal of FS Series Module as 
shown in Fig.3-1. 

 
Fig. 3-1 Min. Clearance for Installation 

3.3 IO Installation and Removal of IO Module 
3.3.1 IO Installation of IO Module 
1. Pull out the rail buckle under the module with a slotted screwdriver; 
2. Hang the module onto the DIN35 guide rail, and the lower guide rail buckle is pushed inside and 
locked with a slotted screwdriver as shown in Fig.3-2. 
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Fig.3-2 Installation of Module 
3.3.2 Removal of IO Module 
1. Pull out the guide rail buckle under the module with a slotted screwdriver; 
2. Put out the module slightly and form an angle with the DIN35 guide rail before the module pushed 
upward as shown in Fig.3-3. 

 
Fig.3-3 Removal of Module 

4 Dimension Drawing and Wiring Diagram for Module 

4.1 Dimension Drawing for Module 
External dimensions of all modules in FS series shall remain consistent with equal length, width 
and height. 
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Fig.4-1 Dimension Drawing for Module 

4.2 Wiring Diagram for Module Power Source 
See Fig.4-3 for the wiring diagram of EtherCAT, PROFINET, CC-Link and CC-Link IE Field Basic 
Bus Remote IO Module Power Source in FS series. 

 
Fig.4-3 Wiring Diagram for Power Source 

In FS series, the wiring diagram for DeviceNet Bus Remote IO Module is inconsistent with modules 
of other bus protocols as shown in Fig.4-4. 
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Fig.4-4 Wiring Diagram for Power Source 

4.3 Wiring Diagram for Digital Quantities Input Channel 
In the FS Series Remote IO Modules, all input channels support NPN and PNP. However, only one 
signal type (NPN or PNP) can be used in the process of operation. 
4.3.1 Wiring Diagram for NPN Signal for Digital Quantities Input Channel 

 
Fig. 4-5 NPN Wiring for Digital Quantities Input Channel 
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4.3.1 Wiring Diagram for PNP Signal for Digital Quantities Input Channel 

 
Fig. 4-5 PNP Wiring for Digital Quantities Input Channel 

4.4 Wiring Diagram for Digital Quantities Output  
4.4.1 NPN Wiring Diagram for Digital Quantities Output 

 

Fig.4-6 NPN Wiring for Digital Quantities Output Channel 

Load
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4.4.2 PNP Wiring Diagram for Digital Quantities Output 

 

Fig.4-6 PNP Wiring for Digital Quantities Output Channel 
4.5 Wiring Diagram for Relay Output 
4.5.1 Wiring Diagram for Relay Output DC Load 

 

Fig.4-7 Wiring Diagram for Relay Output DC Load 

Load

LoadLoad
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4.5.2 Wiring Diagram for Relay Output AC Load 

 
Fig.4-8 Wiring Diagram for Relay Output AC Load 

5 FS IO Configuration 

The chapter mainly introduces the links between FS Series Remote IO Module and the 
current main PLC in industrial field and the configuration thereof, including the 
configuration of the programming software and the parameter configuration of some 
modules. 

5.1 Link between EtherCAT Protocol IO Module and PLC 
5.1.1 Link between TwinCAT3 and EtherCAT Protocol IO Module and 
Configuration 
1. See Fig. 5-1-1 for the communication link diagram. 

 
Fig. 5-1-1 Communication Link Diagram 

2. Hardware configuration is shown in Table 5-1-2. 
Table 5-1-2 Hardware Configuration 

Hardware Qty Note 
Programming Computer 1 TwinCAT3 Installed 

EC-8800-C0NN 1 EtherCAT Protocol 
8DI/8DO Module 

Network Cable >1  
3. Installation of XML Description File 

Load Load

Programming 
Computer
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The XML description file is installed to TwinCAT3 as shown in Fig. 5-1-3. The default 
folder is (C:\TwinCAT\3.1\Config\Io\EtherCAT). 

 
Fig. 5-1-3 Installation of XML Description File 

4. New Project and device Configuration 
Open the TwinCAT software and select “File”>Create>Project as shown in Fig.5-1-4. 
Select “TwinCAT projects” in the window of the new project as shown in Fig. 5-1-5. 

 
Fig. 5-1-4 New Project 

 
Fig. 5-1-5 Selection of TwinCAT Project 

IO that is connected with the programming computer will be scanned into the project 
and click “I/O”>“Devices”>“Scan” in the project tree as shown in Fig. 5-1-6. The 
hardware configuration that is scanned is shown in Fig. 5-1-7. 
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Fig. 5-1-6 Scan Device for IO 

 
Fig. 5-1-7 Hardware Configuration 

5.1.2 IO Module Link and Configuration of CODESYS and EtherCAT Protocol 
1. See Fig. 5-1-8 for the communication link diagram. 

 
Fig. 5-1-8 Communication Link Diagram 

2. See Table 5-1-2 for hardware configuration. 
Table 5-1-2 Hardware Configuration 

Hardware Qty Note 
Programming Computer 1 Codesys V3.5 Installed 

EC-8800-C0NN 1 EtherCAT Protocol 

Programming 
Computer

Codesys V3.5



FS System Remote IO-User Manual                               

 

34

8DI/8DO Module 
Network Cable >1  

3. Installation of XML Description File 
Open CODESYS V3.5 software and select “Tool”>“Device Memory Library” from the 
Menu Bar as shown in Fig. 5-1-9. 

 
Fig. 5-1-9 Installation of XML Device Description File  

4. New Project and Device Configuration 
Open CODESYS V3.5 software and select “New Project”>“Project”>“Standard project” 
as shown in Fig. 5-1-10. 
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Fig. 5-1-10 New Project 

Select “CODESYS SoftMotion Win V3” in the Device from the window of Standard 
Project and select the Structural Text (ST) for the PLC_PRG programming language as 
shown in Fig. 5-1-11. 

 
Fig. 5-1-11 Selection of Device and Programming Language 

Note: Softmotion can be provided with Drive and IO. The Control however can only be 
provided with IO rather than the Drive. 
Select “Device(CODESYS SoftMotion Win V3)”>“Add Device” in the device tree as 
shown in Fig. 5-1-12. And select the “Canbus”>“EtherCAT”>“EtherCA“Device 
(CODESYS SoftMotion Win V3)”>“Add Device” T Master” in the window of Add 
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Device as shown in Fig. 5-1-13. 

 
Fig. 5-1-12 Addition of Device 

 
Fig. 5-1-13 Selection of EtherCAT Bus 

Assign ethernet for EtherCAT Master and double click the 
“EtherCAT_Master”>“EtherCAT NIC Setting”> “Browse” in the device tree as shown 
in Fig. 5-1-14. 
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Fig. 5-1-14 Assignment of Ethernet 

Note: The project shall be downloaded into the controller before assignment of the ethernet. 
Manually add IO module into the device tree and click “EtherCAT Master”>“Add Device” via right 
click. Select “EC-8800-C0NN” in the window of Device as shown in Fig. 5-1-15. 

 
5. Programme Download and Monitoring 
Select “Online”>”Log in” in the Menu and confirm the download before enabling the 
programme. Select the “Debug”>“Enable” in the Menu. 
5.1.3 IO Module Link and Configuration of Sysmac Studio and EtherCAT Protocol 
1. See Fig. 5-1-16 for the communication link diagram. 
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Fig. 5-1-16 Communication Link Diagram 

2. See Table 5-1-3 for the hardware configuration. 
Table 5-1-3 Hardware Configuration 

Hardware Qty Note 
Programming Computer 1 Sysmac Studio 

Controller 1 NJN301-1100 

EC-8800-C0NN 1 EtherCAT Protocol 
8DI/8DO Module 

Network Cable >1  
3. Installation of XML Description File 
XML description file is installed into the Sysmac Studio as shown in Fig. 5-1-17. 
Default Folder: 
C:\ProgramFiles(x86)\OMRON\SysmacStudio\IODeviceProfiles\EsiFiles\UserEsiFiles) 

 
Fig. 5-1-17 Installation of XML Description File 

4. New Project and Device Configuration 
Open Sysmac Studio and select the “New Project” which will be configured with the 
device model and version number as shown in Fig. 5-1-18. 

 

Programming 
Computer
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Fig. 5-1-18 New Project 
Add the adapter and double click “EtherCAT” in the multi-view browser. Select “FS 
Series” in the Toolbox and further select “EC-8800-C0NN-V3” under the Toolbox as 
shown in Fig. 5-1-19. 

 

Fig.5-1-19 Addition of Module 
Click the Online icon, place the mouse on the icon of the master device and perform 
the right click. Select the write-in from the device node address (the default node of the 
WELL-LINK EtherCAT slave device is 0, so the node number must be set), as shown 
in figure 5-1-20. 

 
Fig. 5-1-20 Write-in of Node Address 

Note: The device needs to be restarted after write-in of the node address, and then the 
node address will take effect. 
The program will be downloaded into the Control after restart of the device. Select 
“Controller”>“Transmission”>“Transmission to Controller (T)” as shown in Fig. 5-1-
21. 
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Fig.5-1-21 Program Download 

5.2 IO Module and PLC Link (PN Module) of PROFINET Protocol 
5.2.1 IO Module Link and Configuration of TIA Portal and PROFINET Protocol 
1. See Fig. 5-2-1 for the communication link diagram. 

 
Fig. 5-2-1 Communication Link Diagram 

2. See Table 5-2-1 for hardware configuration. 
Table 5-2-1 Hardware Configuration 

Hardware Qty Note 
Programming Computer 1 TIA Portal V16 Installed 

Controller 1 S7-1212C 

PN-HH00-C1NN 1 PROFINET Protocol 
16DI/16DO Module 

Network Cable >1  
3. Installation of GSD File 
Open TIA Portal V16 and select “Option”>“Support Device Description File (GSD)” 
in the Menu as shown in Fig. 5-2-2. 

Programming Computer
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Fig.5-2-2 Installation of GSD File 

4. New Project and Device Configuration 
Open TIA Portal V16 and select the new project which will be configured as shown in 
Fig.5-2-3. 

 
Fig.5-2-3 New Project 

In regards of the device configuration, you can shift to the network view window and 
unfold the hardware catalog on the right side. Select and drag PN-HH00-C1NN into the 
network view as shown in Fig.5-2-4. 
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Fig.5-2-4 Device Configuration 

In the network view, the Controller will be assigned to the Remote IO Module. Click 
the “Unassigned” in the IO Module and select PLC_1.PROFINET Interface_1 as shown 
in Fig. 5-2-5. 

 
Fig.5-2-5 Assignment of IO Controller 

Set IP address for IO Module. Double click the module in the device view and enter the 
attribute view as shown in Fig.5-2-6. 
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Fig.5-2-6 Assignment of IP Address 
Assign the device name for the Remote IO Module. Select the “Assign Device Name” 
in the module with right click as shown in Fig. 5-2-7. Select the interface type, update 
the list and assign the device name as shown in Fig. 5-2-8. 

   
Fig. 5-2-7 Assignment of Device Name         Fig.5-2-8 Write-in of Device Name 

Select and download all the devices in the network view as shown in Fig. 5-2-9. After 
download of the program, start and operate CPU. Then shift to the online monitoring 
of communication and and assure the normality. See Fig.5-2-10 for details. 

 
Fig.5-2-10 Program Download 
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+  
Fig.5-2-11 Device Monitoring 

5.2.2 IO Module Link and Configuration of Step7 smart and PROFINET Protocol 
1. See Fig. 5-2-12 for the communication link diagram. 

 
Fig. 5-2-12 Communication Link Diagram 

2. See Table 5-2-2 for hardware configuration. 
Table 5-2-2 Hardware Configuration 

Hardware Qty Note 

Programming Computer 1 STEP7-MicroWIN 
SMART Installed 

Controller 1 CPU ST40(DC/DC/DC) 

PN-HH00-C1NN 1 PROFINET Protocol 
16DI/16DO Module 

Network Cable >1  
3. Installation of GSD File 
Open STEP7-MicroWIN SMART and select “GSDML Administration” in the Menu as shown in Fig.5-2-13. 

 
Fig.5-2-13 Installation of GSD File 

Programming 
Computer
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4. Assignment of Device Name 
Select “Tool”>“Search PROFINET Device” in the Menu. Select the network card 
connected to the Module in the window and search the device. Select the module in the 
network and edit the device name as shown in Fig. 5-2-14. 
Note:  
①When selecting the network card, the same network card will have 2 options as shown 
in the figure below. It is required to select the network card without Auto. 

 
②After assignment of device name, be noted that the used device name must be consistent 
with the aforesaid assigned name upon IO Module configuration. Otherwise, PLC cannot 
normally communicate with the IO Module. 

 
Fig. 5-2-14 Assignment of Device Name 

5. New Project and Device Configuration 
Select “Tool”>“PROFINET” in the Menu and then select PLC role as the controller as 
shown in Fig. 5-2-15. Add IO Module and assign the device name (consistent with the 
assigned device name as mentioned in Step 4) and the IP address so as to confirm the 
creation. See Fig. 5-2-16 for details. 
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Fig.5-2-15 Selection of PLC Role 

 
Fig. 5-2-16 Assignment of Device Name and IP Address 

6. Program Download 
Select “PLC”>“Download” in the Menu and select “Search CPU” in the 
communication window. Select PLC requiring for program download and download 
the program. 
Note: When PROFINET communication of 200 SMART configured by STEP 7-MicroWIN 
SMART, the CPU firmware version of PLC shall be at least (≥) V2.4. If the firmware version 
equals (=) V2.3, the firmware can be directly upgraded online. If the firmware version is below 
(<) 2.3, such firmware must be updated with the memory card in CPU. 
 
5.2.3 IO Module Link and Configuration of Step7 and PROFINET Protocol 
1. See Fig. 5-2-17 for the communication link diagram. 

 
Fig. 5-2-17 Communication Link Diagram 

 
2. See Table 5-2-3 for hardware configuration. 

Table 5-2-3 Hardware Configuration 
Hardware Qty Note 

Programming Computer 1 Step7 V5.6 Installed 
Controller 1 315-2 PN/DP 

PN-HH00-C1NN 1 PROFINET Protocol 

Programming 
Computer
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16DI/16DO Module 
Network Cable >1  

3. Installation of GSD File 
Create the new project. Click “SIMATIC300” and double click “Hardware”. In the HW Config 
window, select “Option”>“Install GSD File” in the Menu as shown in Fig. 5-2-18. 

 
Fig. 5-2-18 Installation of GSD File 

4. New Project and Device Configuration 
Open SIMATIC Manager and select “New Project” in the Menu. Name the project and 
select the save path as shown in Fig.5-2-19/ 

 
Fig.5-2-19 New Project 

Add station 300 to the project as shown in Fig. 5-2-20. Click the newly added station 300, select 
"Hardware", and enter the HW config configuration interface as shown in Fig. 5-2-21. Add RACK 
RL of RACK 300 as shown in Fig. 5-2-22. Add the CPU module, select the version V2.6 of 
CPU315-2 PN/DP of CPU-300 in the right window of HW config, and drag it to slot 2 of the rack 
with the mouse as shown in Fig. 5-2-23. In the attribute interface of the Ethernet interface, other IP 
addresses can be used as needed. Here, the default IP address and subnet mask are used. Select the 
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Create button, and create a new subnet Ethernet (1). Click OK. See Fig. 5-2-24 for details. 
 

 
Fig. 5-2-20 Addition of Station 300 

 
Fig. 5-2-21 HW Config Interface 
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Fig. 5-2-22 Addition of Rack Rl 

   
Fig.5-2-23 Add CPU Module into Framework 

 
Fig 5-2-24 Add Ethernet in subnet 

In Ethernet (1), Set I/O device station config. Select PN-HH00-C1NN on the right side 
and drag under Ethernet(1) subnet, as shown in Fig. 5-2-25 
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Fig. 5-2-25 Add IO Module into Ethernet（1）subnet 

Change I/O device station IP address, double click DEC module from subnet.  
Select "Ethernet" in the attribute window, and the IP address can be modified from it, as shown in 
Fig. 5-2-26 

 

Fig. 5-2-26 Change Module IP address 
Set the device name of the IO module, select the subnet icon, select "PLC" from Menu, select 
"Ethernet" > "Assign Device Name", as shown in Fig. 5-2-27. In the assign device name window, 
select the name to be assigned, and press the "Confirm Name" button, as shown in Fig. 5-2-28. 
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Fig. 5-2-27 Select Assign Device Name 

 
Fig. 5-2-28 Assign Device Name 

Check if the name is assigned successfully, select the subnet icon, select "PLC" from 
the Menu, and select "Ethernet "> "Verify Device Name", as shown in Fig. 5-2-29. 
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Fig.5-2-29 Verify Device Name 
5.2.4 Connection of CODESYS and PROFINET Protocol IO Module and Other Configurations 
1. Connection of CODESYS and PROFINET Protocol IO Module and other 
configurations 

 
Fig.5-2-30 Communication Connection Diagram 

2. See Table 5-2-4 for hardware configuration. 
Table 5-2-4 Hardware Configuration 

Hardware QTY Note 
Programming Computer 1 Codesys V3.5 Installed 

PN-HH00-C1NN 1 PROFINET Protocol 
16DI/16DO Module 

Network Cable ＞1  
3. Installation of GSD File 
Open CODESYS V3.5, select "Tool" > "Device Memory Library" from Menu as shown 
as in Fig. 5-2-31. 

Programming 
Computer
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Fig. 5-2-31 Installation of GSD File 

4. New Project and Device Configuration 
Open CODESYS V3, select “New Project”>“Project”>“Standard Project” as shown as 
Fig. 5-2-33. 

 
Fig. 5-2-33 New Project 

Select " CODESYS SoftMotion Win V3" in the standard project window. Select 
"Structured Text" (ST) for PLC_ PRG programming language as shown in Fig. 5-2-34. 
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Fig. 5-2-34. Select Device and Programming Language 

In the device tree, select " Device (CODESYS SoftMotion Win V3") > "Add Device", 
add the Ethernet adapter and PROFINET IO Master Station respectively, as shown in 
Fig. 5-2-35 and Fig. 5-2-36. 
Note: Configure PROFINET IO in the original CoDeSys software. If error, then it 
means the miss of Library, user needs to double-click the Library Manager and select 
to download the missing Library in the Library Manager window. The overall process 
requires the network connection. In addition, the IP address and network segment of 
the network interface connected to the IO device,  to prevent that the IP address of the 
IO device is not sharing the same network while setting. 

 

Fig. 5-2-35 Add Ethernet Adaptor 
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Fig.5-2-36 Add PROFINET IO Master Station 

Double click "Ethernet" in the device tree to allocate the Ethernet port and set the IP parameters 
of the PROFINET IO main station, as shown in Fig. 5-2-37 and Fig. 5-2-38. 

 
Fig. 5-2-37 Ethernet Port 

 
Fig.5-2-38 Set PROFINET IO Main Station IP 

Download the program to the Controller and start running, and then exit. Right click 
PN_ Controller, select "Scan Device", in the device window, select the Module, and 
assign the device name and IP address, as shown in Fig. 5-2-39. Copy the device to the 
project, as shown in Fig. 5-2-40. 
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Fig. 5-2-39 Assign Name and IP Address 

 
Fig. 5-2-40 Copy Device to Project 

5. Program Download and Device Monitor 
Download the project to the controller, and start running and monitoring, shown as Fig. 
5-2-41. 
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Fig. 5-2-41 Program Download and Monitoring 

5.3 Connection between CC-Link IE Field Basic Protocol IO Module and PLC 
5.3.1 GX-Works2 and CC-Link IE Field Basic Protocol IO Module Connection and Configuration 

1. See Fig. 5-3-1 for communication link diagram. 

 
Fig. 5-3-1 Communication Link Diagram 

2. See Table 5-3-1 for hardware configuration. 
Table 5-5-1 Hardware Configuration 

Hardware Qty Note 

Programming Computer 1 GX-Works2 Installed 

Controller 1 L02 

CI-HH00-C0NN 1 
CC-Link IE Field BasicProtocol 

16DI/16DOModule 

Network Cable >1  

3. Installation of File Description 
Open GX-Works2 programming software, select "Tools" > "Configuration File "> 
"login" in the Menu bar, as shown in Fig. 5-3-1, and select the Description File to be 
installed. 
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Fig.5-3-1 Installation of Description File 

4. New Project 
Open GX-Works2 software, select "Project" > "New" in the Menu, and select PLC 
series, CPU model and programming language. Take L Series CPU as an example here, 
as shown in Fig. 5-3-2. 

 
Fig.5-3-2 Select PLC Type 

CC-Link IE Field Basic parameter setting： select "Parameters" > "PLC parameters" 
from the left navigation, select "Built-In Ethernet Port Setting" in the L parameter 
setting window, and set the IP and sub mask(code) of the PLC Main station. then, click 
"CC-Link IE Field Basic" as shown in Fig. 5-3-3 
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Fig.5-3-3 Set PLC IP Address and Sub-net Mask 

From CC-Link IE Field Basic setting window， tick CC-Link IE Field Basic. Click 
network configuration settings, as shown in Fig. 5-3-4. 

 
Fig. 5-3-4 Network Configuration Setting 

Add Module 1: Manually, from CC-Link IE Field Basic configuration window. Drag 
the IO module (right side) to the CPU at the bottom left for configuration, as shown in 
Fig. 5-3-5. 
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 Fig. 5-3-5 Manual Addition of Module 

Module Addition 2: Scan the modules in the network into the device configuration, and 
select "Automatic Detection of Connected Devices" in the CC-Link IE Field Basic 
configuration window, as shown in Fig. 5-3-6. 

 
Fig. 5-3-6 Scan Module in Network 

Modify the Module IP address (the default IP address is 192.168.1.88). From the CC-
Link IE Field Basic configuration window, double-click the module IP address bar to 
modify the IP address. After the modification, right-click module the IP address and 
select "online" > "Reflect the Communication Settings of the Station" to complete the 
IP address modification, as shown in Fig. 5-3-7. Finally, click "Reflect the Settings and 
Close" as shown in Fig. 5-3-8. 
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Fig. 5-3-7 Modification of Module IP Address 

 
Fig. 5-3-8 Reflection of Setting and Closing 

For IO mapping configuration, set the starting point of the input and output of the 
Remote IO Module from the CC-Link IE Field Basic configuration window as shown 
in Fig. 5-3-9. 
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Fig. 5-3-9 IO Mapping Configuration 

5. CC-Link IE Field Basic output point reflection method: each slave occupies 64 points, 
as 64DI and 64DO. The input and output points set here related to starting points X100 
and Y100. The reflection of slave station IO points is shown in Fig. 5-3-10. 

 
Fig. 5-3-10 Slave Station IO Point Mapping 

6. Communication Status Diagnosis 
After the parameter configuration setting, the communication status can be tested 
through online diagnosis after downloading the project to the PLC. Select "Diagnosis" > 
"CC-Link IE Field Basic Diagnosis" from the Menu, and check the slave station status 
of IO module from the CC-Link IE field Basic diagnosis window, as shown in Fig. 5-
3-11. 
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Fig. 5-3-11 Communication Status Diagnosis 

5.4 IO Module and PLC Link of CC-Link Protocol 
5.4.1 IO Module Link and Configuration of GX-Works2 and CC-Link Protocol 
1. See Fig. 5-4-1 for communication link diagram. 

 
Fig. 5-4-1 Communication Link Diagram 

2. See Table 5-4-1 for hardware configuration. 
Table 5-4-1 Hardware Configuration 

Hardware QTY Note 
Programming Computer 1 GX-Works2 Installed 

PLC 1 Support CC-Link protocol 

CL-HH00-C0NN 1 CC-Link Protocol 
16DI/16DO Module 

CC-Link Communication Wire >1  
3. New Project and Communication Parameters Configuration 
Open GX-Works2, select the actual onsite CPU Type, and then "Parameters" > 
"Network Parameters >" CC-Link " in the navigation (left side) of the project. Set CC 
link slave station setting parameters in the CC-Link parameter setting window, as 
shown in Fig. 5-4-2 and the CC link Network Parameters, as shown in Fig. 5-4-3. 
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Fig. 5-4-2 Open CC-Link Parameter Setting Window  

 
Fig. 5-4-3 CC-Link Parameter Setting 

4. CC-Link Module Communication Address Assignment 
FS series CC-Link protocol remote IO modules use CC-Link as remote IO stations. 
Each module includes 32DI and 32DO (specified in Mitsubishi CC link protocol). 
Module address assignment and usage are shown in Fig. 5-4-4. 
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Fig. 5-4-4 CC-Link Address Assignment 

5.5 IO Module and PLC Link of DeviceNet Protocol 
5.5.1 IO Module Link and Configuration of CX-one and DeviceNet Protocol 
Note: CX one and EX-101 includes manual and Auto modes. Please refer to Fig. 5.3.1 for  
detail 4 and detail 5. 
1. See Fig. 5-5-1 for the communication link diagram. 

 
Fig. 5-5-1 Communication Link Diagram 

Note: The power interface of DeviceNet adapter needs to be connected to the DC24V power 
supply separately，and the two terminal modules in the network shall add with the terminal 
resistance, shown in Fig. 5-5-2 below. 
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Fig. 5-5-2 Terminal Resistance Wiring 

2. See Table 5-5-1 for hardware configuration. 
Table 5-5-1 Hardware Configuration 

Hardware QTY Remark 
Programming Computer 1 CX-one 

Controller 1 CJ2M/ CJ1W-DR2M 

DN-HH00-C0NN 1 DeviceNet Protocol 
16DI/16DO Module 

DeviceNet 通讯线 >1  
3. Installation of EDS File 
Open CX-Integrator configuration software, and select "Tool" > "DeviceNet Tool" > 
"Edit Configuration File" > "Supplier ID// Device Type List" in the Menu as shown in 
Fig. 5-5-3. 

 
Fig.5-5-3 Installation of EDS File 

4. Device Configuration (Automatic Scanning) 
Open CX-Integrator configuration software, select "Network" > "Communication 
Setting" in the menu, and select the PLC model as " CJ2M（CPU Type：CPU31)" as 
shown in Fig.5-5-4. 
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Fig.5-5-4  Set CPU Configuration 

As for the Auto scanning, Click “Online Working Button” ， Double- Click 
DeviceNet[CJ1W-DRM21] Network（-），Node (1), unit (0), and name the network to 
confirm the transmission, as shown in Fig.5-5-5. Double click DN-HH00-C0NN, then 
you can check if OMRON PLC scanned to DN-HH00-C0NN slave station. 

 
Fig.5-5-5 Automatic Scanning 

5. Device Configuration (Manual) 
Right click “New Project”. Select “add network”. Select “DeviceNet” shown as in 
Fig.5-5-6. 
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Fig.5-5-6 Addition of Network 

From network, add DeviveNet communication module CJ1W-DRM21 first, then add 
IO devices, right-click the network Fig. label > "Insert component", and select DN-
HH00-C0NN in the guild window, as shown in Fig.5-5-7. 

 
Fig.5-5-7 Addition of Remote IO Module 

6. Download of Configuration Information 
Right-Click “CJ1W-DR2M”Fig. Label，select “Parameter”>“Edit ” as shown in Fig.5-
5-8. 
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Fig.5-5-8 Open Parameter Edit 

 
In the Edit Device Parameters window, select the "registration button" to set the Remark 
book from the slave station as shown in Fig.5-5-9. After successful registration, you 
can see the internal address of the PLC of the input and output of the slave station IO 
module. Finally, click the "Download" to download the configuration information to 
the PLC as shown in Fig.5-5-10. After downloading, you can see that the NET RUN 
light on the adapter is lit, and the SYS light flashes once per second. 

 
Fig.5-5-9 Slave Station Device Registration 
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Fig. 5-5-10 Configuration Download 

 
 
 

5.6 IO Module and PLC Link of CANopen Protocol 
5.6.1 IO IO Module Link and Configuration of AutoShop and CANopen Protocol 
1. See Fig.5-6-1 for the communication link diagram. 

 
Fig.5-6-1 Communication Link Diagram 

Note: The power interface on the CANopen adapter needs to be separately connected to the DC24V 
power supply, and the two terminal modules needs to add with the terminal resistance in the network. 
The connection of the terminal resistance is shown in Fig. 5-6-2 below. 



FS System Remote IO-User Manual                               

 

71

 
Fig.5-6-2 Terminal Resistance Connection 

2. See Table 5-6-1 for hardware configuration. 
Table 5-6-1 Hardware Configuration 

Hardware QTY Note 
Programming Computer 1 AutoShop 

Controller 1 H5U-A8 

CA-8800-C0NN 1 CANopen Protocol 
8DI/8DO Module 

Communication Wire >1  
3. Installation of EDS File 
Open the AutoShop programming and create the project, select the related CPU Type, 
right-click " CAN（CANopen）" in the left, then select "add CAN configuration", 
double-click the CANopen configuration, and right-click the blank area in the right 
CANopen device list to select "Import EDS", as shown in Fig.5-6-3. 

 
Fig.5-6-3 Installation of EDS File  

4. Project Creation 
Open AutoShop software, select the actual model corresponding to H5U and create the 
project. Double click " CAN（CANLink）" in the left configuration of the project, 
change the protocol type to CANopen, and set the communication rate to 125kbps as 
shown in Fig.5-6-4. 
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Fig.5-6-4 CANopen Communication Parameter Setting 

Right click " CAN (CANLink)" of the project configuration on left side, select "add 
CAN configuration", and CA-8800-C0NN module in CANopen configuration, as 
shown in Fig.5-6-5. 

 
Fig. 5-6-5 Addition of CANopen Module 

Double click the CA-8800-C0NN module in the configuration and configure the node 
ID (Note: the node ID must be consistent with the address set by the actual address dial 
switch, otherwise the normal communication will not be influenced), as shown in Fig.5-
6-7, check the IO mapping address of the actual CANopen module, as shown in Fig.5-
6-8. 
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Fig. 5-6-7 Node ID Setting 

 
Fig.5-6-8 IO Address Mapping 

Note: In the case, D700 _ L stores the value of 8 channels of digital output. D7400_ L stores 
the value of 8 channels of digital input. 
5.6.2 IO IO Module Link and Configuration of InoProShop and CANopen 
Protocol 
1. See Fig. 5-6-9 for the communication link diagram. 

 
Fig. 5-6-9 Communication Link Diagram 

Note: The power interface on the CANopen adapter needs to be separately connected to the DC24V 
power supply, and the two terminal modules needs to add with the terminal resistance in the network. 
The connection of the terminal resistance is shown in Fig. 5-6-10 below. 
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Fig.5-6-10 Terminal Resistance Wiring 
2. See Table 5-6-2 for the hardware configuration. 

Table 5-6-2 Hardware Configuration 
Hardware QTY Note 

Programming Computer 1 InoProShop 
Controller 1 AM401-1608 

CA-8800-C0NN 1 CANopen Protocol 
8DI/8DO Module 

Communication Wire >1  
3. Installation of EDS File 
Open the InoProSho programming software, select "Tool"> "Device Library" from the 
Menu. Select "Install" in the device library window, and select the EDS file to be 
installed, as shown in Fig.5-6-11. 

 
Fig.5-6-11 Installation of EDS File 

4. Project Creation 
Open the InoProShop programming software to create the project, select the actual 
related CPU Type, double-click to open " LocalBus Config " in the project 
configuration on the left, and click CPU to select "CANopen Master", as shown in 
Fig.5-6-12. 
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Fig.5-6-12 CANopen Configuration 

From the left side device list, double-click “CANOPEN (CANopen Master)” to 
configure the CANopen Master Station Communication Parameter，as shown in Fig.5-
6-13 

 
Fig.5-6-13 CANopen Master Communication Parameter Configuration 

Double-click “Network Configuration” from configuration window. Add “CA-8800-
C0NN” in the third-party manufacturer in the CANopen list from network devices list 
as shown in Fig.5-6-14. 

 
Fig.5-6-14 Addition of CANopen Module 

From the device list, double-click CA-8800-C0NN module, and configure the node ID 
(the node ID must be consistent with the address set by the actual address dial switch, 
otherwise normal communication will be influenced), as shown in Fig.5-6-15. Check 
the IO mapping address of the actual CANopen module, as shown in Fig.5-6-16. 
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Fig. 5-6-15 Node ID Setting 

 
Fig. 5-6-16 IO Address Mapping 

5.7 IO Module and PLC Link (E12 Module) of EtherNet/IP Protocol 
5.7.1 IO Module Link and Configuration of KV STUDIO and EtherNet/IP Protocol 
1. See 5-7-1 for the communication link diagram. 

 

Fig. 5-7-1 Communication Link Diagram 
2. See Table 5-7-1 for the hardware configuration. 

Table 5-7-1 Hardware Configuration 
Hardware QTY Note 

Programming Computer 1 KV STUDIO, IP Setting 
Tool Software 

PLC 1 KV-7500 

EI2-HH00-C1NN 1 EtherNet/IP Protocol 
16DI/16DO Module 

Communication Wire >1  
3. Module IP Address Setting 
Open IP Setting Tool, select the network card connected to the module and scan the 
online IO module as shown in Fig.5-7-2. 
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Fig.5-7-2 Scan Online IO Module 

Select the module IP needs to be modified in the scan list (Note: the module factory 
default is BOOTP startup, and there is no IP address. After setting the IP address, please 
select fixed IP startup), as shown in Fig.5-7-3. 

 
Fig. 5-7-3 IP Address Setting 

Advice: The module does not have an IP address as default. Before configuring, first set 
the IPv4 of the PC network card to the same network segment as the IP of the module 
requiring for setup. 
4. Installation of EDS File 
Open KV STUDIO, create new project, double click "EtherNet/IP " in the project 
device tree to open the EtehrNET/IP setting window, and select "EDS File" > "login" 
from menu, as shown in Fig.5-7-4. 

 
Fig. 5-7-4 Installation of EDS File 

5. New Project and Device Configuration 
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Open KV STUDIO, create new project. Double-click “EtherNet/IP” and open 
EtehrNET/IP setting window from project device tree. Manually add EI2-HH00-C1NN 
into EtherNet/IP list as shown in Fig.5-7-5. 

 
Fig.5-7-5 Manually add EI2-HH00-C1NN into EtherNet/IP list 

Scan online at EI2-HH00-C1NN adapter (first ensure that the online module and PLC 
are in the same network segment). Select “File ”>“Auto Config.” from EtherNet/IP 
setting window menu as shown in Fig.5-7-6. 

 
Fig.5-7-6 Online scan EI2-HH00-C1NN Module 

Apply the configuration, download the configuration and program to the PLC, and 
monitor the module operation status, as shown in Fig.5-7-7. 

 
Fig.5-7-7 Operating and Monitoring 
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5.7.2 IO Module Link and Configuration of Machine Expert and EtherNet/IP Protocol 
1. See Table 5-7-8 for the communication link diagram. 

 
Fig.5-7-8 Communication Link Diagram 

2. See Table 5-7-8 for the hardware configuration. 
Table 5-7-8 Hardware Configuration 

Hardware QTY Note 

Programming Computer 1 Machine Expert,IP Setting 
Tool 

PLC 1 M241 

EI2-HH00-C1NN 1 EtherNet/IP Protocol 
16DI/16DO Module 

Communication Wire >1  
3. Module IP Address Setting 
Open IP Setting Tool. Select the network card connected to the module and scan the 
online IO module, as shown in Fig.5-7-9. 

 
Fig.5-7-9 Scan Online IO Module 

Select the module IP needs to be modified in the scan list (Note: the module factory 
default is BOOTP startup, and there is no IP address. After setting the IP address, please 
select fixed IP startup), as shown in Fig.5-7-10. 
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Fig.5-7-10 IP Address Setting 

Advice: The module does not have an IP address as default. Before configuring, first set the 
IPv4 of the PC network card to the same network segment as the IP of the module requiring 
for setup. 
4. Installation of EDS File 
Open the machine expert V2.0 programming, select "Tool" > "Device Memory 
Library" from the menu, select "Install" in the device Memory Library window, as 
shown in Fig.5-7-2. Select " EI2-HH00-C1NN " under the EDS folder and confirm the 
installation. 

 
Fig.5-7-11 Installation of EDS File 

5. New Project and Device Configuration 
Open Machine Expert V2.0, create a project, and right-click " EtherNET_1" under the 
device tree to select "add Device", as shown in Fig.5-7-12. 
From the add device window, select " Protocol Manager" > "Industrial Ethernet 
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Manager", as shown in Fig.5-7-13. Right-click "_ (Industrial Ethernet Manager) >" add 
Device "under the device tree. Select the supplier “DECOWELL AUTOMATION 
CO.,LTD” in the device window. Select “ EI2-HH00-C1NN” in the device category as 
shown in Fig.5-7-14. 

 
Fig.5-7-12 Addition of Device 

 
Fig.5-7-13  Add Industrial Ethernet Manager 



FS System Remote IO-User Manual                               

 

82

 
Fig.5-7-14 Add EI2-HH00-C1NN 

To configure EI2-HH00-C1NN Parameter, double-click “EI2-HH00-C1NN” from 
device tree and configure the IP address as the fixed IP address as shown in Fig.5-7-15. 

 
Fig.5-7-15 Configuration of IP Address 

Check the IO address mapping. Double-click “EI2-HH00-C1NN” from the device tree 
and perform IO Mapping from EtherNet/IP as shown in Fig. Fig.5-7-16. 

 
Fig.5-7-16 IO Address Mapping 
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5.7.3 IO Module Link and Configuration of CODESYS and EtherNet/IP Protocol 
1. See Fig. 5-7-8 for the communication link diagram. 

 
Fig. 5-7-17 Communication Link Diagram 

2. See Table 5-7-3 for the hardware configuration. 
Table 5-7-3 Hardware Configuration 

Hardware QTY Note 
Programming Computer 1 Codesys SP16,IP Setting Tool 

PLC 1  

EI2-HH00-C1NN 1 
EtherNet/IP Protocol 
16DI/16DO Module 

Communication Wire >1  

3. Module IP Address Setting 
Open IP Setting Tool, select the network card connected with module, and scan the 
online IO Module as shown in Fig.5-7-18. 

 
Fig.5-7-18 Online Scan IO Module 

Select the module IP needs to be modified in the scan list (Note: the module factory 
default is BOOTP startup, and there is no IP address. After setting the IP address, please 
select fixed IP startup), as shown in Fig.5-7-1. 
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Fig. 5-7-19 IP Address Setting 

Advice: The module does not have an IP address as default. Before configuring, first set 
the IPv4 of the PC network card to the same network segment as the needed IP of the 
module. 
4. Installation of EDS File 
Open the CODESYS SP16 programming, select "Tool" > "Device Memory Library" 
from the menu, select "Install" in the device Memory Library window, as shown in 
Fig.5-7-20, and select "EI2-HH00-C1NN” under the EDS folder and confirm the 
installation. 

 

Fig.5-7-20 Installation of EDS File 



FS System Remote IO-User Manual                               

 

85

5. New Project and Device Configuration 
Open CODESYS SP16, create project, select “add device” and right click under device 
tree, and select “Ethernet” under add device window, as shown in Fig.5-7-21. 
Select “add device” and right click “Ethernet” from device tree and select “EtherNet/IP 
Scanner” from the add device window as shown in Fig.5-7-22. 

 

Fig.5-7-21 Add Ethernet Adapter 

 

Fig.5-7-22 Add Ethernet IP Scanner 
Configure the network card of the Ethernet adapter, double click "Ethernet" under the 
device tree, and open the page to select the network card that required to communicate 
with the EtherNet/IP slave station as shown in Fig.5-7-23. 



FS System Remote IO-User Manual                               

 

86

 
Fig.5-7-23 Configure Netcard of Ethernet Adapter 

Right click "EtherNet_IP_Scanner" under the device tree, select "add device", and 
select " EI2-HH00-C1NN " in the add device window as shown in Fig.5-7-24. 

 

 
Fig.5-7-24 Add EI2-HH00-C1NN Module 

Configure EI2-HH00-C1NN adapter IP address. Double-click “EI2-HH00-C1NN” 
from device tree. Fill the IP address (the IPS address shall keep consistence with the 
actual Module configuration) as shown in Fig.5-7-25. 
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Fig.5-7-25 Configuration of EI2-HH00-C1NN Module IP Address 

Check the IO address mapping. Double-click “EI2-HH00-C1NN” from device tree. 
Perform mapping under EtherNet/IP I/O as shown in Fig.5-7-26. 

 
Fig.5-7-26 Check IO Address Mapping 

 
5.7.4 IO Module Link and Configuration of Sysmac Studio and EtherNet/IP Protocol 
1. See Fig. 5-7-27 for the communication link diagram. 

 
Fig.5-7-27 Communication Link Diagram 

2. See Table 5-7-4 for the hardware configuration. 
Table 5-7-4 Hardware Configuration 

Hardware QTY Note 
Programming Computer 1 Sysmac Studio,IP Setting Tool 

NX1P2 1  
EI2-HH00-C1NN 1 EtherNet/IP Protocol 
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16DI/16DO Module 
Communication Wire >1  

3. Module IP Address Setting 
Open the IP Setting Tool, select the network card connected to the module, and scan 
the online IO module as shown in Fig.5-7-28. 

 
Fig.5-7-28 Online Scan IO Module 

Select the module IP needs to be modified in the scan list (Note: the module factory 
default is BOOTP startup, and there is no IP address. After setting the IP address, please 
select fixed IP startup), as shown in Fig. Fig.5-7-29. 

 
Fig.5-7-29 IP Address Setting 

Advice: The module does not have an IP address as default. Before configuring, first set 
the IPv4 of the PC network card to the same network segment as the needed IP of the 
module. 
4. New Project and Device Configuration 
Open the Sysmac Studio programming and creation project. Configure the EtherNet/IP 
port to a fixed IP address (consistent with the actual PLC port IP) as shown in Fig.5-7-
30. 
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Fig.5-7-30 EtherNet/IP Portal Setting 

Create all variables, and set input and output variables in overall variables. The 
variables length requires to be consistent with the actual length of input and output 
bytes in the module, as shown in Fig.5-7-31. 

 
Fig.5-7-31 Create Overall Variables 

Select "Tool" > "EtherNet/IP connection settings" from the menu, and double click the 
node address in the EtherNet/IP list window to open the EtherNet/IP port setting link 
settings window as shown in Fig.5-7-32. 
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Fig.5-7-32 Open the EtherNet/IP Port Setting Link Setting Window 

Register variables, select the "Tag Group" window in the built-in EtherNet/I port setting 
link setting window, and click "Register all" to register the newly created overall 
variables, as shown in Fig.5-7-33. 

 
Fig.5-7-33 Register Overall Variables 

 
Install EDS files, right-click in the blank area of the toolbox on the right side of the 
opened built-in EtherNet/IP port setting link setting window and select "display EDS 
library", as shown in Fig.5-7-34. In the EDS Library window, select "Install" and open 
the EDS file to be installed as shown in Fig.5-7-35. 
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Fig.5-7-34 Showing of EDS Library 

 
Fig.5-7-35 Installation of EDS File 

Add the required linked device and configuration parameters, and select "add Target 
Device" in the toolbox, as shown in Fig.5-7-36. The user is required to fill in the 
EtherNet/IP slave IP address, slave type and revision. Afterwards, press the "Add" 
button in the lower left corner of the motor. 

 
Fig.5-7-36 Add Target Device 

Drag and link the target device "192.168.1.65 EI2-HH00-C1NN version 1" in the 
toolbox, as shown in Fig.5-7-37. 
Configure the target device parameters. EI2-HH00-C1NN input target variable is 100, 



FS System Remote IO-User Manual                               

 

92

output target variable is 101, input and output byte size are both 10, and the starting 
variable selects the overall variable after registration as shown in Fig.5-7-38. 
Turn PLC to online, and then to programming mode. Select "Transmit to Controller" 
as shown in Fig.5-7-39. 

 
Fig.5-7-37 Add Connected Device 

 
Fig.5-7-38 Configuration of Target Device Parameters 

 
Fig.5-7-39 Transmit EtherNet/IP Configuration to Controller 

 
 
5.7.5 IO Module Link and Configuration of RSLogix 5000 and EtherNet/IP Protocol 
1. See Fig.5-7-40 for the communication link diagram. 
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Fig.5-7-40 Communication Link Diagram 

 
2. See Table 5-7-5 for hardware configuration 

Table 5-7-5 Hardware Configuration 
Hardware QTY Note 

Programming Computer 1 RSLogix 5000,IP Setting Tool 
1769-L23E-QB1 1 Version: V20 

EI2-HH00-C1NN 1 
EtherNet/IP Protocol 
16DI/16DO Module 

Communication Wire >1  

3. Module IP Address Setting 
Open IP Setting Tool, select the network card connected with Module, and scan the 
online IO Module as shown in Fig. 5-7-41. 

 
Fig.5-7-41 Scan Online IO Module 

Select the module IP needs to be modified in the scan list (Note: the module factory 
default is BOOTP startup, and there is no IP address. After setting the IP address, please 
select fixed IP startup) as shown in Fig. 5-7-42. 
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Fig.5-7-42 IP Address Setting 

Advice: The module does not have an IP address as default. Before configuring, first set 
the IPv4 of the PC network card to the same network segment as the IP of the module 
requiring for setup. 
4. Installation of EDS File 
Open RSLogix 5000, select "Tool" > "EDS Hardware Installation Tool (D)" from the 
menu as shown in Fig.5-7-43. Select the specified folder in the EDS installation window 
as shown in Fig.5-7-44. 

 
Fig.5-7-43 Install EDS File 
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Fig.5-7-44 Select EDS Folder Path 

5. New Project and Device Configuration 
Open RSLogix 5000. Select new project and its’ CPU and version as shown in Fig. 5-
7-45. 

 
Fig.5-7-45 New Project 

Configure EtherNet/IP communication. Select Ethernet and right-click "New Module" 
in the controller manager as shown in Fig.5-7-46. 
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Fig. 5-7-46 New Module 

。Add IO Module. Select DECOWELL from the filter, then select actual IO Module 
Type as shown in Fig.5-7-47. 
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Fig.5-7-47 Selection of IO Module 

Configure Module name and IP address. The IP address must be consistent with the 
actual address. Otherwise it will be unable to link. See Fig.5-7-48 for details. 

 
Fig.5-7-48 Edit Module IP and Name 

Select to communicate with the online PLC and download the program. Select 
"Communication" >" Activity Item" from the menu. Select the online CPU as shown 
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in Fig.5-7-49. Download the program to the PLC as shown in Fig.5-7-50. 

 
Fig.5-7-49 Select to Communicate with Online PLC 

 
Fig.5-7-50 Download Program to PLC 

 
Monitor whether the communication is working normally. Turn the CPU to the online 
status, and monitor whether the EI2-HH00-C1NN communication is normal. See Fig.5-
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7-51 for details. 

 
Fig.5-7-51 Monitor Module Operation Status 

5.8 IO Module and PLC Link of PROFINET Protocol 
5.8.1 IO Module Link and Configuration of TIA Portal and PROFINET Protocol 
1. See Fig. 5-8-1 for the communication link diagram. 
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Fig. 5-8-1 Communication Link Diagram 

2. See Table 508-1 for the hardware configuration. 
Table 5-8-1 Hardware Configuration 

Hardware QTY Note 
Programming Computer 1 TIA Portal V16 Installed 

Controller 1 S7-1212C 

PN2-HH00-C1NN 1 PROFINET Protocol 
16DI/16DO Module 

Network Cable >1  
3. Installation of GSD File 
Open TIA Portal V16 and select “Options” > “Support Device Description file (GSD)” 
from the menu bar, as shown in Fig.5-8-2. 

 
Fig.5-2-2 Installation of GSD File 

4. New Project and Device Configuration 
Open TIA Portal V16, select New project and configure as shown in Fig.5-2-3 
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Fig.5-2-3 New Project 

Configure device, switch to the network view, unfold the hardware category on the right, 
select PN2-HH00-C1NN and drag it to the network view as shown in Fig.5-8-4. 

 
Fig. 5-8-4 Device Configuration 

Assign a controller to the remote IO module in the network view. Click "Unassigned" 
in the IO module and select PLC_ 1. PROFINET interface_ 1, as shown in Fig.5-8-5. 
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Fig.5-8-5 Assign IO Controller 

Configure IO Module IP address. Double-click Module and enter attribute view in the 
device view as shown in Fig.5-8-6. 

 
Fig. 5-8-6 Assignment of IP Address 

The remote IO Module assigns the device name. Right-click the module and select 
"Assign Device Name" as shown in Fig.5-8-7. Select the interface type and update the 
list and assign the name as shown in Fig.5-8-8. 
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Fig.5-8-7 Assign Device Name    Fig.5-8-8 Write-in of Device Name 
As for the module input / output IO port parameter configuration, double click "PN2-
HH00-C1NN" in the network view and configure the input filtering time (3ms as 
default, and the range is 0.5ms-10ms) as shown in Fig.5-8-9. When the CPU is in STOP 
status, the module output status (the default output is 0, FALSE, which can be 
configured to output 0/1 or maintain the previous value) as shown in Fig.5-8-10. 

 
Fig.5-8-9 Configuration Module Input Channel Filtering Time 
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Fig.5-8-10 Configuration of Module Output Channel Parameter 

Select all devices in the network view and download to PLC. After downloading the 
program, start the CPU and monitor the device status. 
5.8.2 IO Module Link and Configuration of Step7 smart and PROFINET Protocol 
1. See Fig. 5-8-11 for the communication link diagram. 

 
Fig.5-8-11 Communication Configuration Diagram 

 
2. See Table 5-8-2 for the hardware configuration. 

Table 5-8-2 Hardware Configuration 
Hardware QTY Note 

Programming Computer 1 STEP7-MicroWIN SMART Installed 

Controller 1 CPU ST40(DC/DC/DC) 

PN2-HH00-C1NN 1 
PROFINET Protocol 16DI/16DO 

Module 
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Network Cable >1  

3. Installation of GSD File 
Open STEP7-MicroWIN SMART. Select “GSDML Manage” from Menu as shown in 
Fig.5-8-12. 

 
Fig. 5-8-12 Installation of GSD File 

4. Assignment of Device Name 
Select "Tool" > "Search PROFINET device" from the menu, select the network card 
connected to the module in the window and find the device, select the Module in the 
network and edit its device name as shown in Fig.5-8-13. 
Note: 
①When selecting a network card, two options will appear for the same network card, as 
shown in figure below. Then select a network card without Auto. 

 
② After the device name is assigned, please note that when configuring the IO module, 
the device name must be consistent with the name assigned above, otherwise the PLC will 
not be able to link with the IO module normally. 
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Fig.5-8-13 Assignment of Device Name 

5. New Project and Device Configuration 
Select "Tool" > "PROFINET" from the menu. Select the PLC role as the controller as 
shown in Fig.5-8-14. Add the IO Module, assign the device name (should consistent 
with the device name assigned in step 4 above) and IP address, and confirm assigned 
successful, as shown in Fig.5-8-15. 

 
Fig.5-8-14 Selection of PLC Role 
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Fig. 5-8-15 Assignment of Device Name and IP Address 

As for the module input / output IO port parameter configuration and in the PROFINET, 
configure the input filtering time (3ms as default, and the range is 0.5ms-10ms) in the 
guide window as shown in Fig. 5-8-16. When the CPU is in STOP, and the module is 
in output status (the default output is 0, FALSE, which can be configured to output 0/1 
or maintain the previous value), as shown in Fig. 5-8-17. 

 
Fig.5-8-16 Configuration Module Input Channel Filter Time 
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Fig.5-8-17 Configuration Module Output Channel Parameter 

6. Program Download 
Select "PLC" > "Download" from the menu, select "Search CPU" in the communication 
window, select the PLC that needs to download the program, and download the program. 
Note: when using STEP 7-MicroWIN SMART configure 200 SMART PROFINET, the 
CPU firmware version of PLC must be ≥ V2.4. For firmware = V2.3, the firmware can 
be upgraded online directly. For firmware ＜ 2.3, the firmware must be updated in the 
CPU using a memory card. 
 
5.8.3 IO Module Link and Configuration of Step7 and PROFINET Protocol 
1. See Fig.5-8-18 for the communication link diagram. 

 
Fig.5-2-18 Communication Link Diagram 

2. See Table 5-8-3 for the hardware configuration. 
Table 5-8-3 Hardware Configuration 

Hardware QTY Note 
Programming Computer 1 Step7 V5.6 Installed 

Controller 1 315-2 PN/DP 
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PN2-HH00-C1NN 1 PROFINET Protocol 
16DI/16DO Module 

Network Cable >1  
3. Installation of GSD File 
After create new project, click “SIMATIC300”. Double-click “Hardware”. Select 
“Options”>“Install GSD File” from menu in the HW Config. Window as shown in 
Fig.5-8-19. 

 

Fig. 5-8-19 Installation of GSD File 
4. New Project and Device Configuration 
Open SIMATIC Manager. Select “New project ” from menu and name the project. 
Select project save path as shown in Fig.5-8-20. 
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Fig. 5-8-20 New Project 

Add station 300 to the project as shown in Fig. 5-8-21. Click the newly added station 300, select 
"Hardware", and enter the HW config configuration interface as shown in Fig. 5-8-22. Add RACK 
Rl of RACK 300 as shown in Fig. 5-8-23. Add the CPU module, select the version V2.6 of CPU315-
2 PN/DP of CPU-300 in the right window of HW config, and drag it to slot 2 of the rack with the 
mouse as shown in Fig. 5-8-24. In the attribute interface of the Ethernet interface, other IP addresses 
can be used as needed. Here, the default IP address and subnet mask are used. Select the Create 
button, and create a new subnet Ethernet (1). Click OK. See Fig. 5-8-25 for details. 
 
 

 
Fig.5-8-21 Add Station 300 
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Fig.5-8-22 HW Config Interface 

 
Fig.5-8-23 Add Rack Rl 
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Fig.5-8-24 Add CPU Module to Rack 

 
Fig.5-8-25 Add Ethernet Subnet 

Configure IO Device Station in Ethernet (1). Select PN2-HH00-C1NN on the right and 
drag it to the Ethernet (1) subnet, as shown in Fig.5-8-26. 
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Fig.5-8-26 Add IO Module into Ethernet(1) Subnet 
Modify the IP address of the IO device station, double click PN2-HH00-C1NN 

Module in the subnet, select "Ethernet" in the attribute window, and modify the IP 
address from it , as shown in Fig.5-8-27. 

 

 
Fig.5-8-27 Modify Module IP Address 

Set the device name of the IO module, select the subnet icon, select "PLC" from the 
menu, select "Ethernet" > "assign device name", as shown in Fig.5-8-28. In the assign 
device name window, select the name to be assigned, and press the "confirm name" 
button, as shown in Fig.5-8-29. 
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Fig.5-8-29 Assign Device Name 

As for the module input / output IO port parameter configuration, configure the input 
filtering time (3ms as default, and the range is 0.5ms-10ms) in the module slot. When 
the CPU is in STOP status, the module output status (the default output is 0, FALSE, 
which can be configured to output 0/1 or maintain the previous value), as shown in Fig. 
5-8-30. 

 
Fig. 5-8-30 Module Input/Output IO Port Parameters Configuration 
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Annex 

Summary of PO Details of FS Series Products 

FS One-piece-PROFINET Communication Protocol Digital Quantities Input/Output Module 
Model Descriptions PO No. 

PN-8800-C0NN 
PROFINET 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (NPN) 
00-01-01 

PN-8800-C1NN 
PROFINET 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (PNP) 
00-01-02 

PN-8800-C2NN 
PROFINET 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (Relay) 
00-01-03 

PN-HH00-C0NN 
PROFINET 16-channel digital quantities 

input(NPN&PNP)16-channel digital quantities output (NPN) 
00-01-04 

PN-HH00-C1NN 
PROFINET 16-channel digital quantities 

input(NPN&PNP)16-channel digital quantities output (PNP) 
00-01-05 

PN-S000-CNNN PROFINET 32-channel digital quantities input (NPN&PNP) 00-01-08 

PN-0S00-N0NN PROFINET 32-channel digital quantities output (NPN) 00-01-09 

PN-0S00-N1NN PROFINET 32-channel digital quantities output(PNP) 00-01-10 

FS One-piece-EtherCAT Communication Protocol Digital Quantities Input/Output Module 
Model Descriptions PO No. 

EC-8800-C0NN 
EtherCAT 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output(NPN) 
00-02-01 

EC-8800-C1NN 
EtherCAT 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output(PNP) 
00-02-02 

EC-8800-C2NN 
EtherCAT 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (Relay) 
00-02-03 

EC-HH00-C0NN 
EtherCAT 16-channel digital quantities input(NPN&PNP)16-

channel digital quantities output(NPN) 
00-02-04 

EC-HH00-C1NN 
EtherCAT 16-channel digital quantities input(NPN&PNP)16-

channel digital quantities output(PNP) 
00-02-05 

EC-S000-CNNN EtherCAT 32-channel digital quantities input(NPN&PNP) 00-02-08 
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EC-0S00-N0NN EtherCAT 32-channel digital quantities output(NPN) 00-02-09 

EC-0S00-N1NN EtherCAT 32-channel digital quantities output(PNP) 00-02-10 

FS One-piece-CC-Link Communication Protocol Digital Quantities Input/Output Module 
Model Descriptions PO No. 

CL-8800-C0NN 
CC-LINK 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output(NPN) 
00-03-01 

CL-8800-C1NN 
CC-LINK 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output(PNP) 
00-03-02 

CL-8800-C2NN 
CC-LINK 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (Relay) 
00-03-03 

CL-HH00-C0NN 
CC-LINK 16-channel digital quantities input(NPN&PNP)16-

channel digital quantities output(NPN) 
00-03-04 

CL-HH00-C1NN 
CC-LINK 16-channel digital quantities input(NPN&PNP)16-

channel digital quantities output(PNP) 
00-03-05 

CL-S000-CNNN CC-LINK 32-channel digital quantities input(NPN&PNP) 00-03-07 

CL-0S00-N0NN CC-LINK 32-channel digital quantities output(NPN) 00-03-08 

CL-0S00-N1NN CC-LINK 32-channel digital quantities output (PNP) 00-03-09 

FS One-piece-DeviceNet Communication Protocol Digital Quantities Input/Output Module 
Model Descriptions PO No. 

DN-8800-C0NN 
DEVICENET 8-channel digital quantities 

input(NPN&PNP)8-channel digital quantities output (NPN) 
00-04-01 

DN-8800-C1NN 
DEVICENET 8-channel digital quantities 

input(NPN&PNP)8-channel digital quantities output (PNP) 
00-04-02 

DN-8800-C2NN 
DEVICENET 8-channel digital quantities 

input(NPN&PNP)8-channel digital quantities output (Relay) 
00-04-03 

DN-HH00-C0NN 
DEVICENET 16-channel digital quantities 

input(NPN&PNP)16-channel digital quantities output (NPN) 
00-04-04 

DN-HH00-C1NN 
DEVICENET 16-channel digital quantities 

input(NPN&PNP)16-channel digital quantities output (PNP) 
00-04-05 

DN-S000-CNNN 
DEVICENET 32-channel digital quantities 

input(NPN&PNP) 
00-04-08 
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DN-0S00-N0NN DEVICENET 32-channel digital quantities output (NPN) 00-04-09 

DN-0S00-N1NN DEVICENET 32-channel digital quantities output (PNP) 00-04-10 

FS One-piece- CC-Link IE Field Basic Communication Protocol Digital Quantities 
Input/Output Module 

Model Descriptions PO No. 

CI-8800-C0NN 
CC-Link IE Field Basic 8-channel digital quantities 

input(NPN&PNP)8-channel digital quantities output (NPN) 
00-06-01 

CI-8800-C1NN 
CC-Link IE Field Basic 8-channel digital quantities 

input(NPN&PNP)8-channel digital quantities output(PNP) 
00-06-02 

CI-8800-C2NN 
CC-Link IE Field Basic 8-channel digital quantities 

input(NPN&PNP)8-channel digital quantities output (Relay) 
00-06-03 

CI-HH00-C0NN 
CC-Link IE Field Basic 16-channel digital quantities 

input(NPN&PNP)16-channel digital quantities output (NPN) 
00-06-04 

CI-HH00-C1NN 
CC-Link IE Field Basic 16-channel digital quantities 

input(NPN&PNP)16-channel digital quantities output (PNP) 
00-06-05 

CI-S000-CNNN 
CC-Link IE Field Basic 32-channel digital quantities input 

(NPN&PNP) 
00-06-06 

CI-0S00-N0NN 
CC-Link IE Field Basic 32-channel digital quantities output 

(NPN) 
00-06-07 

CI-0S00-N1NN 
CC-Link IE Field Basic 32-channel digital quantities 

output(PNP) 
00-06-08 

FSOne-piece-PROFINET Communication Protocol Digital Quantities Input/Output Module 
Model Descriptions PO No. 

PN2-8800-C0NN 
PROFINET 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output(NPN) 
00-01-11 

PN2-8800-C1NN 
PROFINET 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output(PNP) 
00-01-12 

PN2-8800-C2NN 
PROFINET 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (Relay) 
00-01-13 

PN2-HH00-
C0NN 

PROFINET 16-channel digital quantities 
input(NPN&PNP)16-channel digital quantities output(NPN) 

00-01-14 

PN2-HH00-
C1NN 

PROFINET 16-channel digital quantities 
input(NPN&PNP)16-channel digital quantities output(PNP) 

00-01-15 
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PN2-S000-
CNNN 

PROFINET 32-channel digital quantities input(NPN&PNP) 00-01-18 

PN2-0S00-N0NN PROFINET 32-channel digital quantities output(NPN) 00-01-19 

PN2-0S00-N1NN PROFINET 32-channel digital quantities output(PNP) 00-01-20 

FS One-piece-EtherNet/IP Communication Protocol Digital Quantities Input/Output Module 
Model Descriptions PO No. 

EI2-8800-C0NN 
EtherNet/IP 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (NPN) 
00-05-11 

EI2-8800-C1NN 
EtherNet/IP 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (PNP) 
00-05-12 

EI2-8800-C2NN 
EtherNet/IP 8-channel digital quantities input(NPN&PNP)8-

channel digital quantities output (Relay) 
00-05-13 

EI2-HH00-C0NN 
EtherNet/IP 16-channel digital quantities 

input(NPN&PNP)16-channel digital quantities output (NPN) 
00-05-14 

EI2-HH00-C1NN 
EtherNet/IP 16-channel digital quantities 

input(NPN&PNP)16-channel digital quantities output (PNP) 
00-05-15 

EI2-S000-CNNN EtherNet/IP 32-channel digital quantities input (NPN&PNP) 00-05-16 

EI2-0S00-N0NN EtherNet/IP 32-channel digital quantities output (NPN) 00-05-17 

EI2-0S00-N1NN EtherNet/IP 32-channel digital quantities output (PNP) 00-05-18 


